CIT Ticketing system and Customer portal outage

Incident Report for CIT Services Status

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 09:26 CST

Update

A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 09:20 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 09:13 CST

Investigating

We are working with the Vendor on this issue.
Posted Dec 02, 2025 - 09:01 CST
This incident affected: Third Party Services (CIT Ticketing System and Customer Portal).