CIT Colo Internet Issue affecting Hosted Websites and CIT Ticket system

Incident Report for CIT Services Status

Resolved

Our Internet Provider has confirmed they resolved the issue on their side that was creating the problem for our service.
Posted Apr 24, 2025 - 13:53 CDT

Update

We are continuing to monitor for any further issues.
Posted Apr 24, 2025 - 13:52 CDT

Monitoring

We are continuing to work with the Internet provider, but we think we have found the root issue. We have bypassed the problem connection and are monitoring to ensure speed and stability are as expected.
Posted Apr 23, 2025 - 12:14 CDT

Investigating

We are again seeing timeout issues accessing resources at the colo.
Posted Apr 23, 2025 - 07:38 CDT

Monitoring

Have a fix in place and performance appears to be back to normal.
Posted Apr 22, 2025 - 22:07 CDT

Update

Still Trouble shooting the performance / reliability issue on the Internet service.
Posted Apr 22, 2025 - 20:51 CDT

Identified

We have identified what we think is the core issue and have rebooted affected devices. We are continuing to investigate to be sure we have resolved the problem. Currently looks like services are up.
Posted Apr 22, 2025 - 14:13 CDT

Investigating

We are currently investigating this issue.
Posted Apr 22, 2025 - 08:41 CDT
This incident affected: CIT Colo Hosting Services (CIT Colo) and Managed Services (CIT Ticketing System and Customer Portal).